ArcEmu: Cannot Compile "install" - ArcEmu

Jump to content

Toggle shoutbox Lastest Announcements

dfighter  : (07 December 2014 - 12:06 PM) Arcemu is in hibernation mode, please read http://arcemu.org/fo...showtopic=26903
dfighter  : (01 January 2013 - 05:56 PM) Arcemu wishes you all a happy new year!
Hasbro  : (12 September 2012 - 10:01 AM) Please excuse our outage from the web! Our web host had a major malfunction!
dfighter  : (01 September 2012 - 04:05 PM) Since the spam bots just don't want to stop, I've enabled admin verification when registering.
dfighter  : (23 January 2012 - 09:56 PM) Please note that from now on you will need to confirm your email on the wiki in order to edit it!
Hasbro  : (31 December 2011 - 12:50 PM) Happy New Years all!
Navid  : (26 December 2011 - 04:09 AM) Merry Christmas !!!!!! Happy holidays all :)
WAmadeus  : (24 December 2011 - 03:54 PM) Merry Christmas to all!
dfighter  : (24 December 2011 - 11:05 AM) The Arcemu team wishes y'all a Merry Christmukkah!
Hasbro  : (05 October 2011 - 12:53 PM) Looking for web designers for upcoming web related project. If you're interested in designing user interfaces contact me
dfighter  : (02 September 2011 - 03:47 PM) So who here wants vehicles in Arcemu? :P http://arcemu.org/fo...showtopic=25440
Hasbro  : (14 August 2011 - 03:25 PM) Join us on irc, grab an irc client and connect to irc.freenode.net join channel #arcemu /server irc.freenode.net:6667 /join #arcemu
jackpoz  : (03 August 2011 - 05:33 AM) to all Lua Engine (old one) users: please check http://arcemu.org/fo...showtopic=25274
Hasbro  : (20 May 2011 - 05:27 PM) Looking for people experienced with CMake configuration and setup! Contact me asap
Hasbro  : (15 May 2011 - 05:03 PM) ArcEmu is recruiting C++ programmers, contact Hasbro if interested.
paroxysm  : (03 May 2011 - 06:26 PM) Updated luabridge gossip example to describe the whole gossip creation process rather than just how to create menu. Gossip tutorial
paroxysm  : (23 April 2011 - 11:35 AM) Lua writers can refer to the Luabridge Tutorials section in the Wiki to learn how to write gossip code correctly.
Hasbro  : (20 April 2011 - 05:22 PM) Thank you for your continuous contribution of bug reports, we are working on them.
Hasbro  : (17 April 2011 - 03:20 AM) Please consider donating to support our bills. Donations can be sent using PayPal to donations@arcemu.org - Thank you for your support.
paroxysm  : (10 April 2011 - 12:43 AM) Refer to the Luabridge Tutorials section in the Wiki to learn the new syntax of luabridge.
Resize Shouts Area

Page 1 of 1
  • You cannot start a new topic
  • This topic is locked

Cannot Compile "install"

#1 User is offline   blh868 

  • Member
  • Pip
  • Group: Members
  • Posts: 73
  • Joined: 16-July 08
  • Gender:Male
  • Location:U.S.A.
  • Server OS:Windows

Posted 27 May 2011 - 04:46 PM

Well, it's been a long while since I've tried to compile, and this whole cmake thing seems to be causing me a little trouble. Anyone have any idea why it is giving me this error when trying to build only the "INSTALL" portion of the project? Everything else has compiled fine up to this point.

1>------ Build started: Project: INSTALL, Configuration: Release Win32 ------
1>Build started 5/27/2011 4:43:08 PM.
1>InitializeBuildStatus:
1>  Touching "Win32\Release\INSTALL\INSTALL.unsuccessfulbuild".
1>PostBuildEvent:
1>  -- Install configuration: "Release"
1>  CMake Error at logon/cmake_install.cmake:35 (FILE):
1>    file cannot create directory: C:/Program Files (x86)/Project/bin.  Maybe
1>    need administrative privileges.
1>  Call Stack (most recent call first):
1>    cmake_install.cmake:36 (INCLUDE)
1>  
1>  
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Microsoft.CppCommon.targets(113,5): error MSB3073: The command ""C:\Program Files (x86)\CMake 2.8\bin\cmake.exe" -DBUILD_TYPE=Release -P cmake_install.cmake
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Microsoft.CppCommon.targets(113,5): error MSB3073: if errorlevel 1 goto :VCEnd
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Microsoft.CppCommon.targets(113,5): error MSB3073: :VCEnd" exited with code 1.
1>
1>Build FAILED.
1>
1>Time Elapsed 00:00:00.14
========== Build: 0 succeeded, 1 failed, 18 up-to-date, 0 skipped ==========

0

#2 User is offline   dfighter 

  • Titles are overrated
  • PipPipPipPipPipPipPipPipPipPip
  • Group: Administrator
  • Posts: 5,189
  • Joined: 14-June 08
  • IRC:dfighter
  • Gender:Male
  • Server OS:Linux

Posted 27 May 2011 - 04:53 PM

Hi there!

It tells you what's wrong

Quote

cannot create directory: C:/Program Files (x86)/Project/bin. Maybe need administrative privileges.

"The demand for free goods is infinite."
0

#3 User is offline   blh868 

  • Member
  • Pip
  • Group: Members
  • Posts: 73
  • Joined: 16-July 08
  • Gender:Male
  • Location:U.S.A.
  • Server OS:Windows

Posted 27 May 2011 - 04:58 PM

Yeah I considered that, but wasn't sure how to give it admin priv! I mean, I am the admin account on my computer lol

Thank you for responding. ;)

Edit: I'm trying to sort it out.
0

#4 User is offline   paroxysm 

  • Chatty Cathy
  • Group: Retired
  • Posts: 320
  • Joined: 25-June 08
  • Gender:Male
  • Server OS:Windows

Posted 27 May 2011 - 05:06 PM

Try running cmd/cmake-gui as administrator.
0

#5 User is offline   blh868 

  • Member
  • Pip
  • Group: Members
  • Posts: 73
  • Joined: 16-July 08
  • Gender:Male
  • Location:U.S.A.
  • Server OS:Windows

Posted 27 May 2011 - 05:10 PM

Solution for anyone else who may run into this little annoyance:

locate the file: \program files\microsoft visual studio 10.0\Common7\IDE\devenv.exe

right click this file >> Properties >> Compatability >> Change Settings for all users >> "Run this program as an administrator"

Or you can simply just check that box if you don't need to enable it for other users, assuming that you are on your administrative account.

cheers. ;)

Edit: Silly windows /sigh
0

#6 User is offline   dfighter 

  • Titles are overrated
  • PipPipPipPipPipPipPipPipPipPip
  • Group: Administrator
  • Posts: 5,189
  • Joined: 14-June 08
  • IRC:dfighter
  • Gender:Male
  • Server OS:Linux

Posted 27 May 2011 - 05:48 PM

You should also probably set the installation path as described here http://arcemu.org/wi...g_the_CMake_GUI
Probably the reason you got this error in the first place was that you didn't set that and just left it on the default ;)
"The demand for free goods is infinite."
0

#7 User is offline   blh868 

  • Member
  • Pip
  • Group: Members
  • Posts: 73
  • Joined: 16-July 08
  • Gender:Male
  • Location:U.S.A.
  • Server OS:Windows

Posted 27 May 2011 - 06:26 PM

Ah thank you very much! I must have missed that. Seems so different to me considering the last time I compiled I didn't even know that CMake existed. Thanks again ;)
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • This topic is locked

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users