ArcEmu: Problem With Db [ubuntu] - ArcEmu

Jump to content

Toggle shoutbox Lastest Announcements

dfighter  : (07 December 2014 - 12:06 PM) Arcemu is in hibernation mode, please read http://arcemu.org/fo...showtopic=26903
dfighter  : (01 January 2013 - 05:56 PM) Arcemu wishes you all a happy new year!
Hasbro  : (12 September 2012 - 10:01 AM) Please excuse our outage from the web! Our web host had a major malfunction!
dfighter  : (01 September 2012 - 04:05 PM) Since the spam bots just don't want to stop, I've enabled admin verification when registering.
dfighter  : (23 January 2012 - 09:56 PM) Please note that from now on you will need to confirm your email on the wiki in order to edit it!
Hasbro  : (31 December 2011 - 12:50 PM) Happy New Years all!
Navid  : (26 December 2011 - 04:09 AM) Merry Christmas !!!!!! Happy holidays all :)
WAmadeus  : (24 December 2011 - 03:54 PM) Merry Christmas to all!
dfighter  : (24 December 2011 - 11:05 AM) The Arcemu team wishes y'all a Merry Christmukkah!
Hasbro  : (05 October 2011 - 12:53 PM) Looking for web designers for upcoming web related project. If you're interested in designing user interfaces contact me
dfighter  : (02 September 2011 - 03:47 PM) So who here wants vehicles in Arcemu? :P http://arcemu.org/fo...showtopic=25440
Hasbro  : (14 August 2011 - 03:25 PM) Join us on irc, grab an irc client and connect to irc.freenode.net join channel #arcemu /server irc.freenode.net:6667 /join #arcemu
jackpoz  : (03 August 2011 - 05:33 AM) to all Lua Engine (old one) users: please check http://arcemu.org/fo...showtopic=25274
Hasbro  : (20 May 2011 - 05:27 PM) Looking for people experienced with CMake configuration and setup! Contact me asap
Hasbro  : (15 May 2011 - 05:03 PM) ArcEmu is recruiting C++ programmers, contact Hasbro if interested.
paroxysm  : (03 May 2011 - 06:26 PM) Updated luabridge gossip example to describe the whole gossip creation process rather than just how to create menu. Gossip tutorial
paroxysm  : (23 April 2011 - 11:35 AM) Lua writers can refer to the Luabridge Tutorials section in the Wiki to learn how to write gossip code correctly.
Hasbro  : (20 April 2011 - 05:22 PM) Thank you for your continuous contribution of bug reports, we are working on them.
Hasbro  : (17 April 2011 - 03:20 AM) Please consider donating to support our bills. Donations can be sent using PayPal to donations@arcemu.org - Thank you for your support.
paroxysm  : (10 April 2011 - 12:43 AM) Refer to the Luabridge Tutorials section in the Wiki to learn the new syntax of luabridge.
Resize Shouts Area

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Problem With Db [ubuntu] World database version doesn't match

#1 User is offline   kaskull 

  • Newbie
  • Group: Members
  • Posts: 4
  • Joined: 09-February 11
  • Gender:Male
  • Server OS:Linux

Posted 02 March 2011 - 08:36 AM

Hi evreybody, i've a big problem with DB.

I've done all the steps of the wiki, and i've create my DB with WhyDB.

I try to execute world: "./arcemu-world"

[14:33][Arcemu]ArcEmu 4.0-TRUNK r4031/Release-Linux-X86 :: World Server
[14:33][Arcemu]ArcEmu 4.0-TRUNK r4031/Release-Linux-X86 :: World Server
The key combination <Ctrl-C> will safely shut down the server at any time.[14:33][Arcemu]Config: Loading Config Files...
[14:33][Arcemu]Database: Character database version doesn't match the required version which is 3800.
[14:33][Arcemu]Database: You need to apply the character update queries that start with a larger number than 3955. Exiting.

Ok no problem, i go to my phpmyadmin, and i edit "arcemu_db_version" instet of 3955 I put 3800.

I execute "./arcemu-world"

[14:35][Arcemu][2011-03-02 14:35:32]
[14:35][Arcemu][2011-03-02 14:35:32]
[14:35][Arcemu]ArcEmu 4.0-TRUNK r4031/Release-Linux-X86 :: World Server
[14:35][Arcemu]ArcEmu 4.0-TRUNK r4031/Release-Linux-X86 :: World Server
The key combination <Ctrl-C> will safely shut down the server at any time.[14:35][Arcemu]Config: Loading Config Files...
[14:35][Arcemu]Database: World database version doesn't match the required version which is 3955.
[14:35][Arcemu]Database: You need to apply the world update queries that start with a larger number than 3800. Exiting.

OMG? Is this a BUCLE? xd

HELP ME PLEASE
0

#2 User is offline   jackpoz 

  • ArcEmu Lemon Priest
  • PipPipPipPipPipPipPipPip
  • Group: Developers
  • Posts: 2,153
  • Joined: 19-June 08
  • Gender:Male
  • Location:Italy
  • Server OS:Windows

Posted 02 March 2011 - 08:50 AM

View Postkaskull, on 02 March 2011 - 08:36 AM, said:

I've done all the steps of the wiki
...
[14:33][Arcemu]Database: You need to apply the character update queries that start with a larger number than 3955. Exiting.
...
Ok no problem, i go to my phpmyadmin, and i edit "arcemu_db_version" instet of 3955 I put 3800.

I read "You need to apply the character update queries that start with a larger number than 3955", not "You need to go to your phpmyadmin, and edit 'arcemu_db_version'".
http://arcemu.org/wi...ating_databases also says:

Quote

Create three databases: name them arc_logon, arc_characters and arc_world.

is this what you did or you went naf and used the same database for both characters and world?
Posted Image We develop dreams. Your dreams ;)
Posted ImagePosted Image
1

#3 User is offline   Desconocido 

  • Newbie
  • Group: Members
  • Posts: 3
  • Joined: 16-October 11
  • Gender:Male
  • Location:Russia
  • Interests:Coding,Music,Life...
  • Server OS:Linux

Posted 18 October 2011 - 10:48 AM

My problem is similar, but I have an error with discrepancy of base of the world at once, without an error of base of characters, use last audit Whydb, has compiled on Debian arcemu-r4635.
You couldn't prompt in what there can be a problem in this case?
0

#4 User is offline   jackpoz 

  • ArcEmu Lemon Priest
  • PipPipPipPipPipPipPipPip
  • Group: Developers
  • Posts: 2,153
  • Joined: 19-June 08
  • Gender:Male
  • Location:Italy
  • Server OS:Windows

Posted 18 October 2011 - 11:51 AM

you have to provide the error that arcemu shows for us to figure out a solution. Also latest WhyDB revision has the outdated structure, so you just have to do exactly what the error message tells you to do: apply the database updates. The wiki has some instructions on how to do it http://www.arcemu.org/wiki/Updating
Posted Image We develop dreams. Your dreams ;)
Posted ImagePosted Image
1

#5 User is offline   Desconocido 

  • Newbie
  • Group: Members
  • Posts: 3
  • Joined: 16-October 11
  • Gender:Male
  • Location:Russia
  • Interests:Coding,Music,Life...
  • Server OS:Linux

Posted 18 October 2011 - 12:09 PM

Thanks for the shown attention, problem has solved by updating of base of the world.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users