ArcEmu: [Applied][Applied]vmap assembler secondary fix - ArcEmu

Jump to content

Toggle shoutbox Lastest Announcements

dfighter  : (07 December 2014 - 12:06 PM) Arcemu is in hibernation mode, please read http://arcemu.org/fo...showtopic=26903
dfighter  : (01 January 2013 - 05:56 PM) Arcemu wishes you all a happy new year!
Hasbro  : (12 September 2012 - 10:01 AM) Please excuse our outage from the web! Our web host had a major malfunction!
dfighter  : (01 September 2012 - 04:05 PM) Since the spam bots just don't want to stop, I've enabled admin verification when registering.
dfighter  : (23 January 2012 - 09:56 PM) Please note that from now on you will need to confirm your email on the wiki in order to edit it!
Hasbro  : (31 December 2011 - 12:50 PM) Happy New Years all!
Navid  : (26 December 2011 - 04:09 AM) Merry Christmas !!!!!! Happy holidays all :)
WAmadeus  : (24 December 2011 - 03:54 PM) Merry Christmas to all!
dfighter  : (24 December 2011 - 11:05 AM) The Arcemu team wishes y'all a Merry Christmukkah!
Hasbro  : (05 October 2011 - 12:53 PM) Looking for web designers for upcoming web related project. If you're interested in designing user interfaces contact me
dfighter  : (02 September 2011 - 03:47 PM) So who here wants vehicles in Arcemu? :P http://arcemu.org/fo...showtopic=25440
Hasbro  : (14 August 2011 - 03:25 PM) Join us on irc, grab an irc client and connect to irc.freenode.net join channel #arcemu /server irc.freenode.net:6667 /join #arcemu
jackpoz  : (03 August 2011 - 05:33 AM) to all Lua Engine (old one) users: please check http://arcemu.org/fo...showtopic=25274
Hasbro  : (20 May 2011 - 05:27 PM) Looking for people experienced with CMake configuration and setup! Contact me asap
Hasbro  : (15 May 2011 - 05:03 PM) ArcEmu is recruiting C++ programmers, contact Hasbro if interested.
paroxysm  : (03 May 2011 - 06:26 PM) Updated luabridge gossip example to describe the whole gossip creation process rather than just how to create menu. Gossip tutorial
paroxysm  : (23 April 2011 - 11:35 AM) Lua writers can refer to the Luabridge Tutorials section in the Wiki to learn how to write gossip code correctly.
Hasbro  : (20 April 2011 - 05:22 PM) Thank you for your continuous contribution of bug reports, we are working on them.
Hasbro  : (17 April 2011 - 03:20 AM) Please consider donating to support our bills. Donations can be sent using PayPal to donations@arcemu.org - Thank you for your support.
paroxysm  : (10 April 2011 - 12:43 AM) Refer to the Luabridge Tutorials section in the Wiki to learn the new syntax of luabridge.
Resize Shouts Area

  • (4 Pages)
  • +
  • « First
  • 2
  • 3
  • 4
  • You cannot start a new topic
  • You cannot reply to this topic

[Applied][Applied]vmap assembler secondary fix [enGB]Makes the vmap data really usable by the server

#61 User is offline   vlack 

  • God of copy-paste
  • PipPipPipPipPipPip
  • Group: Developers
  • Posts: 1,159
  • Joined: 26-July 08
  • Gender:Male
  • Location:Hungary
  • Interests:Helping people who think they're RIL PRO, then come here crying that this or that doesn't work for them.

Posted 02 May 2009 - 07:42 AM

View PostSandile, on May 1 2009, 10:52 PM, said:

The patch doesn't seem to be applied in the latest rev atleast. I compiled the vmap_extractor and vmap_assembler but I still got the bug so I can cast spells through walls and so. So then I tried to manually apply the patch but I got an error:

The patch seems outdated!
	  The file line  
					  char buffer[100];
and the patchline
					  char buffer[100];
do not match!


And btw, what is the vmap_assembler for?

It is still in the core, don't try to apply this a second time.
But you would be thought as a clever person if you weren't asking the last question. It tells me you haven't re-extracted and assembled the content in your vmaps dir. Just compiling the stuff and not using it because you don't know what is it for, tells me everything. If I'm wrong, then sorry, but stupid questions makes me suspicious...
Being an ArcEmu developer requires you to be committed to some specific case. That's why I refuse to be one.
What you see below my name doesn't mean I'm officially affiliated with ArcEmu; I'm still a freelancer programmer, but looks like I have earned that dev. tag.
1

#62 User is offline   kreegoth 

  • Interested
  • PipPipPipPip
  • Group: Members
  • Posts: 381
  • Joined: 28-November 08
  • Location:Outlands

Posted 02 May 2009 - 09:17 AM

I have used the Latest ones and compiled and reextracted.. My problem persists of certain instances mobs not responding to character interaction.

If a player hits the mob it simply stands there and allows the player to hit them.

Other than that this works well.

The places that this is most noticable is in Hellfire Ramparts and in a few custom areas( non instance )

If you can explain why this issue is present so that I can fix it it would be much appreciated.
0

#63 User is offline   Sandile 

  • Member
  • Pip
  • Group: Members
  • Posts: 61
  • Joined: 12-November 08
  • Location:Sweden

Posted 02 May 2009 - 09:41 AM

View Postvlack, on May 2 2009, 01:42 PM, said:

It is still in the core, don't try to apply this a second time.
But you would be thought as a clever person if you weren't asking the last question. It tells me you haven't re-extracted and assembled the content in your vmaps dir. Just compiling the stuff and not using it because you don't know what is it for, tells me everything. If I'm wrong, then sorry, but stupid questions makes me suspicious...

Don't realy get what you mean by this. But I have extracted the vmaps and I have runned the vmap_assembler but there is nothing that describes what the vmap_assembler does.
I don't know what it is for so maby I am stupid? can you try make me smarter by telling me what it does then?
Or am I to dumb? :(
I whould +Rep you if there was any Rep System here.HIHI
0

#64 User is offline   vlack 

  • God of copy-paste
  • PipPipPipPipPipPip
  • Group: Developers
  • Posts: 1,159
  • Joined: 26-July 08
  • Gender:Male
  • Location:Hungary
  • Interests:Helping people who think they're RIL PRO, then come here crying that this or that doesn't work for them.

Posted 02 May 2009 - 12:19 PM

View PostSandile, on May 2 2009, 04:41 PM, said:

Don't realy get what you mean by this. But I have extracted the vmaps and I have runned the vmap_assembler but there is nothing that describes what the vmap_assembler does.
I don't know what it is for so maby I am stupid? can you try make me smarter by telling me what it does then?
Or am I to dumb? :)

No... It uses the contents of the maps folder and the contents of the buildings folder to build up a 3D view of the world from triangles, so it can later do LOS checks. (The buildings folder contains models, so it can be a tree or a cart too, it does not have to be a real building.)
Being an ArcEmu developer requires you to be committed to some specific case. That's why I refuse to be one.
What you see below my name doesn't mean I'm officially affiliated with ArcEmu; I'm still a freelancer programmer, but looks like I have earned that dev. tag.
1

#65 User is offline   Sandile 

  • Member
  • Pip
  • Group: Members
  • Posts: 61
  • Joined: 12-November 08
  • Location:Sweden

  Posted 02 May 2009 - 01:44 PM

View Postvlack, on May 2 2009, 06:19 PM, said:

No... It uses the contents of the maps folder and the contents of the buildings folder to build up a 3D view of the world from triangles, so it can later do LOS checks. (The buildings folder contains models, so it can be a tree or a cart too, it does not have to be a real building.)

Where does this save? the data gathered from the assembler.
And yes I know that the building folder doesn't only contain buildings. Its all wmo files.
Am I suposed to first use vmap_extractor/ad then ad/vmap_extractor and then vmap_assembler?

Edit: Okay I found out what vmap_assembler did now. Dunno why it didn't do anything when I have ran it before. This is the fist time it actually creates the vmap directory. But the problem still occurs. I have collision enabled and I have unload maps enabled I have the right directory on the vmaps and I have vmaps and maps in the correct folder. But I can still cast spells through walls and the mobs can still walk through walls. Is there anything more I need to do when I have gotten the vmaps and placed it in the right folder? :)
I whould +Rep you if there was any Rep System here.HIHI
0

#66 User is offline   Hasbro 

  • Project Manager
  • PipPipPipPipPipPipPipPipPip
  • Group: Administrator
  • Posts: 2,526
  • Joined: 07-June 08
  • Gender:Male
  • Location:New York
  • Server OS:Windows

Posted 03 January 2010 - 12:49 AM

- Applied.
- Moved to applied patches.
0

#67 User is offline   Hasbro 

  • Project Manager
  • PipPipPipPipPipPipPipPipPip
  • Group: Administrator
  • Posts: 2,526
  • Joined: 07-June 08
  • Gender:Male
  • Location:New York
  • Server OS:Windows

Posted 03 January 2010 - 12:49 AM

- Applied.
- Moved to applied patches.
0

Share this topic:


  • (4 Pages)
  • +
  • « First
  • 2
  • 3
  • 4
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users